25 de octubre de 2008

Problema al subir imágenes a Joomla con el Administrador de imágenes

Un compañero ha encontrado hace unos días un pequeño bug en los portales de Joomla con los que trabajamos, en su versión 1.0.15 y la traducción al español. Al intentar eliminar alguna imagen mediante el Administrador de imágenes decía que no.

La solución se encuentra bastante rápido en Internet, hay un hilo en los foros de JoomlaSpanish dedicado al respecto

No puedo eliminar imágenes

La solución rápida es reemplazar el archivo /administrator/components/com_media/admin.media.html.php

por el que se encuentra en el foro: admin.media.html.php

Se puede reemplazar mediante ftp o utilizando el componente JoomlaXplorer.

7 comentarios:

efra dijo...

Una cuestion.... ¿Por qué no vais pensando en cambiar a Joomla 1.5.7 que es la ultima version ?

La version 1.0.x esta paralizada y no hay nuevas actualizaciones, la ultima fue la 1.0.15

Yo estoy migrando a 1.5.7 ya que esta version ya es bastante estable y hay bastantes componentes, modulos y mambots para sustituir a los que usabamos en 1.0.x

Antonio dijo...

Ese es el plan a medio plazo, pero hay que encontrar un rato para migrar los portales actuales al nuevo y que no se note mucho, y que no se corte el servicio, y que no se pierda información, todos esos "yques".

Por otro lado, como sabrás, el mantenimiento de la familia 1.0.x continua durante nueve meses más, hasta el verano aproximadamente.

efra dijo...

no sabia que seguia hasta el proximo verano, ¿Donde lo dicen? Es que mis noticias son que finalizaron en julio de este año....

Antonio dijo...

Lo explica Wilco Jansen, uno de los desarrolladores en esta página:

An old friend comes of age

Básicamente explica que la duración del soporte para la versión 1.0 será hasta el 22 de julio de 2009 (no recordaba la fecha, lo he leído ahora). Hasta ese día se sacarán nuevas revisiones si aparecen problemas de seguridad. A partir de entonces cada cual actuará bajo su propia responsabilidad.

Obviamente lo apropiado sería dar el salto a la 1.5 antes. Estamos todos de acuerdo.

Mónica dijo...

Me he cambiado a Joomla 1.5.7, desde hace años trabajo con 1.0, la verdad es una maravilla el salto excepto por un detalle: no hay manera de que me funcione el gestor para subir imágenes, ¿Alguien tiene un problema semejante? ¿Conoce alguien una posible solución?

Saludos

Antonio dijo...

Asegúrate de que tienes la última versión, probablemente con la 1.5.9, la más actual, no te pase.

Un saludo.

efra dijo...

Yo ya hice mi migración y la verdad que me ha salido de escando y he ganado a mejor.

De paso he aprovechado para un rediseño de mi blog, y he ganado en visitas la verdad.

Sobre el gestor de subir imagenes, dos cosas, mira si tienes el javascript activado o ventana emergentes.... es que aqui es totalmente diferente.

Aunque te digo la verdad, yo para subir imagenes uso la FTP .... mientras redacto el texto y solo tengo que llamarlo desde la carpeta creada.

http://www.melohago.com/